Intermittent audio issues with Clearly Cloud USA

Incident Report for Clearly IP

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 13:55 CDT

Monitoring

We are no longer seeing issues with call quality, however the team is continuing to monitor.
Posted Jun 27, 2025 - 11:35 CDT

Investigating

We are currently investigating reports of intermittent audio issues, choppy or pixilated audio, on our Clearly Cloud USA infrastructure.
Posted Jun 27, 2025 - 11:04 CDT
This incident affected: CloudPBX (Clearly Cloud USA).