Issues Connecting to Clearly Cloud USA

Incident Report for Clearly IP

Resolved

This incident has been resolved.
Posted Feb 19, 2023 - 23:31 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 19, 2023 - 23:14 CST

Investigating

We are aware of issues connecting to Clearly Cloud USA which is also affecting calls. The team is currently investigating the issue and will update when they have more information
Posted Feb 19, 2023 - 23:02 CST
This incident affected: CloudPBX (Clearly Cloud USA).