Clearly Cloud USA down

Incident Report for Clearly IP

Postmortem

At approximately 2:30 PM ET on October 29, alerts began to be received by ClearlyIP's Network Operations team indicating problems accessing the database cluster used by Clearly Cloud for most US-based customers. This was interfering with call routing for a portion of customers and prevented access to Call Panel and other system components. The team immediately began investigating and observed the problem related to a protective mechanism which had detected large amounts of database request traffic and proactively restarted services to prevent data loss or corruption. The source of the requests was quickly identified, stopped, and determined to be legitimate. The team then checked each server in the cluster before determining it was safe to restore normal service by approximately 2:45 PM ET.

A postmortem analysis on the source of the database traffic identified it to be related to delivering an unusual backlog of SMS and email messages from the platform. Temporary measures were taken to prevent a recurrence of the same issue while long-term improvements are scheduled.

Posted Nov 03, 2025 - 10:10 CST

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 14:17 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2025 - 14:02 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 29, 2025 - 13:56 CDT

Investigating

Clearly Cloud USA is currently down and the team is investigating.
Posted Oct 29, 2025 - 13:37 CDT
This incident affected: CloudPBX (Clearly Cloud USA).