XCast Webphone experiencing issues with connecting for users

Incident Report for Clearly IP

Resolved

All web services are back online.
Posted Jul 24, 2025 - 13:23 CDT

Update

ACD Monitor is online.
Posted Jul 24, 2025 - 13:05 CDT

Identified

Web Phone and part of the attendant console are up, still working on the ACD Monitor and Conference Monitor.
Posted Jul 24, 2025 - 12:57 CDT

Investigating

We are currently investigating an issue with the XCast Webphone, attendant console and acd monitor having a spinning red circle and not connecting. This is NOT affecting calls.
Posted Jul 24, 2025 - 10:45 CDT
This incident affected: XCast Labs (Hosted PBX).