Issues with Grandstream devices with XCast Labs

Incident Report for Clearly IP

Monitoring

We have implemented a fix. If you are still having issues with your devices, please contact us by emailing supportcenter@clearlyip.com and we can assist you further.
Posted Apr 04, 2026 - 19:01 CDT

Investigating

We are seeing issues with provisioning and registration of some Grandstream devices. The team is actively reviewing the situation
Posted Apr 03, 2026 - 15:32 CDT
This incident affects: XCast Labs (Hosted PBX, Residential Service, Trunking, Auto Provisioning).